HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 Not really a bug but an issue with using qjackctl as root...

View previous topic View next topic Go down 
AuthorMessage
Schprocket



Posts : 9
Join date : 2011-06-04

PostSubject: Not really a bug but an issue with using qjackctl as root...   Sat Jun 04, 2011 12:23 pm

G'day Remixer!

Schprockie from the Reaper fourm here, mate!

Good to see you've got the forum up and running cheers

Mate, I ended up installing another distro because I wanted to see if there was anything with the use of root qkackctl that was causing me misery with my Native Instruments Kore Controller.

I'm sorry to have to report that as a result of my testing (and eventual fix for my card in the other distro) there is and that I think it will affect many more people who's soundcards don't have mixers - like mine.
(It's got knobs on the panel to set levels)


My sound card is two-channels-in / four-channels-out. The driver for my sound-card is picked up by JACK as only having two-channels-in / two-channels-out.

In order to get around this, I have to create an. asoundrc file which multiplexes the cards two sub-devices, and then, because JACK assumes that all cards are two-in / two-out, create another device using the asym command, and call this second pcm device in qjackctl to have full access to my card.

Now, to run .asound, typically you place it in your user folder which is fine if your audio programs refer to a non-root call to qjackctl.

However because Reaper uses Root JACK CTL, that means I need to drop the .asound file into the root user folder in order to use my sound-card to it's fullest extent in RemixOS.

I know I can change the root password and set this up myself and whilst I'm not likely to stuff up the installation accidentally, there maybe others who might, and by providing some sort of access to the root user folder might be a better proposition if you want to help prevent people from stuffing up their installation when they want to create an .asoundrc file for their soundcard.



In addition, typically it's also helpful to setup the alsa-base.conf file so that the desired audio card is always card 0, else you will always have to be editing the .asoundrc file in order to set the hw address to wherever the card is addressed after boot up - another issue by having to have the .asoundrc file in the root user folder.

This does not seem to be working either because the Kore Controller is still not card 0 after a power-cycling (not warm reboot).

However each distro is a little different and it may be tht there's different file that I'm supposed to use instead.
Back to top Go down
View user profile
Admin
Admin
avatar

Posts : 60
Join date : 2011-05-28

PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   Sat Jun 04, 2011 5:10 pm

Hi Schprocket!

Thank you for the info.
It doesn't need to create a root account. Just copy the file under sudo (changing <username> to your username)

Quote :
sudo cp /home/<username>/.asoundrc /root/.asoundrc


Last edited by Admin on Sun Jun 05, 2011 6:13 am; edited 1 time in total
Back to top Go down
View user profile http://remix-os.forums.gs
Schprocket



Posts : 9
Join date : 2011-06-04

PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   Sun Jun 05, 2011 2:16 am

No problem buddy, we're all here to help each other Smile

I forgot to mention that I also had to delete the section " -P 70" in the server path in order to get user qjackctl to accept my .asoundrc.
I figured that much out as that's how the line was set up in the other distro where I got the same .asoundrc file running successfully.

Thanks for that bit of code, mate. I'm an intermittent user of linux so I need a hand with the commands that I should remember Smile

I had a think about this before I copied the file to /root and found over on the ALSA wiki for ,asoundrc that if the same file was named asound.conf and dropped into /etc that the JACK configuration would be global.
I still used that CLI copy but modified /root to /etc because I'd started to type the string in before I checked the alsa site, so it was easier to edit a few characters than messing around with the gui Smile
However the asound.conf didn't seem to work so I looked up the file delete command (rm - d'Oh! I'd forgotten that too! ) and got rid of it before copying .asoundrc to /root.

I had a personal minor win - a major win in terms of determining that this is the right place to stick the .asoundrc for use with root qjackctl in this distro - but because my USB audio was still card 1 and I had setup .asoundrc for card 0, although Reaper was now giving me all of my outputs, I wasn't getting any capture.
Then to add to the confusion, I'd been testing JACK's acceptence of my mods to the .asoundrc file using the non-root qjackctl, checking the error messages, then running Audacious and somehow got to the point where Root qjackctl couldn't start because Audacious mustn't have 'released' JACK properly.

Anyway, power-cycling the PC then changing just the capture hw: address in the file made all the difference cheers

So the code ended up being (for the current card addressing:

Code:

pcm.multi {
        type multi;
        # bind hardware devices
        slaves.a.pcm "hw:1,0,0"
        slaves.a.channels 2
        slaves.b.pcm "hw:1,0,1"
        slaves.b.channels 2

        # bind channels to virtual device
        bindings.0.slave a
        bindings.0.channel 0
        bindings.1.slave a
        bindings.1.channel 1
        bindings.2.slave b
        bindings.2.channel 0
        bindings.3.slave b
        bindings.3.channel 1
}

ctl.multi {
   type hw
   card 0
}

pcm.jack2x4 {
    # "asym" allows for different
    # handling of in/out devices
    type asym
    playback.pcm {
          # route for mmap workaround
          type route
          slave.pcm "multi"
          ttable.0.0 1
          ttable.1.1 1
          ttable.2.2 1
          ttable.3.3 1
    }
    capture.pcm {
          # 2 channels only
          type hw
          # the next line is the line I had to change for capture
          # this is set to whatever the card address is in the "slaves.a.pcm" definition at the top
          card 1
    }
}


ctl.jack2x4 {
    type hw
    card 0
}

Reaper now works - in terms of interactivity with my Kore Controller 1 - just as it did under Windows and OSX - hope this thread helps anybody else with hardware issues!
Back to top Go down
View user profile
Admin
Admin
avatar

Posts : 60
Join date : 2011-05-28

PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   Sun Jun 05, 2011 6:58 am

Schprocket wrote:
No problem buddy, we're all here to help each other Smile

Sorry. it was a typing mistake )

Schprocket wrote:
...my USB audio was still card 1

Try the following to change:

Code:
sudo su -c 'echo options snd-usb-audio index=-2 >> /etc/modprobe.d/alsa-base'

Back to top Go down
View user profile http://remix-os.forums.gs
Schprocket



Posts : 9
Join date : 2011-06-04

PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   Mon Jun 06, 2011 1:34 pm

I cheat... I navigate through Thunar to /etc right-click on the modprobe.d folder to invoke a terminal session in /etc/modprobe.d, then sudo gedit and open the file that way - I avoid the CLI when I can scratch Smile
Back to top Go down
View user profile
Admin
Admin
avatar

Posts : 60
Join date : 2011-05-28

PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   Mon Jun 06, 2011 9:21 pm

Sorry. The file is alsa-base.conf. You can open it for editing with

Code:
sudo gedit /etc/modeprobe.d/alsa-base.conf
Back to top Go down
View user profile http://remix-os.forums.gs
Sponsored content




PostSubject: Re: Not really a bug but an issue with using qjackctl as root...   

Back to top Go down
 
Not really a bug but an issue with using qjackctl as root...
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Funhouse LP 2010 Rhino reissue
» Confirmation on a confusing issue
» Mojo's Jan. 28 issue out now with feature on Ron Asheton
» Gary Husband in Drumhead Magazine
» Sweet Comfort Band

Permissions in this forum:You cannot reply to topics in this forum
 :: Forums :: Report Bugs-
Jump to: