HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 I can't install KDEnlive

View previous topic View next topic Go down 
AuthorMessage
CodeLurker



Posts : 25
Join date : 2012-03-22

PostSubject: I can't install KDEnlive   Thu Apr 05, 2012 11:04 pm

The Remix_OS distro is the first I was able to get Jack working with my FP10 (previously called the Presonus Firebod - a firewire device) with. I tried to install KDEnlive, but the package manager said that a library with a name like "libmlt2" would not be installed. While I see the video editing applications you have already, I have worked with KDEnlive before, and while it is only vers. 0.81, I think it is more powerful already than the ones which ship with the distro. I wonder if I should install yet another flavor of Linux just to run it. I do see a lot of discussion about including Jack support in KDEnlive, but the feature seems not to be ready yet.

I think it can be made to work, since I followed the advice at this page:

Arch Linux - Jack Flash

and got YouTube videos to play through my Firewire device via Jack. I also played around a lot with the parameters in JackCtl to get it to happen. I tried installing Mepis, but it actually toasted my Remix partition! I reinstalled Remix, and all the pro software in Remix works now; but I haven't yet been able to get flash to play there again. I'll keep trying. What I am saying then, is I don't know how much of KDE it might bring in to make KDEnlive work, nor whether that brings in PulseAudio and thereby breaks Jack; but if these are not show-stoppers, then if KDEnlive only has, say, an ALSA output option, and I can get ALSA sound apps to play out of Jack, then this would be my ideal setup; with details about what desktop to use as secondary to a working Jack. I have read claims elsewhere that PulseAudio breaks Jack, but then there is a PulseAudio to Jack plugin out there too - so it must have worked at one time for the developer. I have heard that KDE pulls in PulseAudio, but I don't know if KDEnlive would have to, itself, either.
Back to top Go down
View user profile
Admin
Admin
avatar

Posts : 60
Join date : 2011-05-28

PostSubject: Re: I can't install KDEnlive   Fri Apr 06, 2012 4:15 am

CodeLurker wrote:
I tried to install KDEnlive, but the package manager said that a library with a name like "libmlt2" would not be installed.
it's because "libmlt4" is installed. You can try to remove it and maybe other ones libmlt packages before, but in that case Openshot won't work.
Back to top Go down
View user profile http://remix-os.forums.gs
CodeLurker



Posts : 25
Join date : 2012-03-22

PostSubject: Re: I can't install KDEnlive   Sat Apr 07, 2012 3:22 pm

That did the trick. Many thanks, Admin rabbit Uninstalling the existing MLT libraries also uninstalled OpenShot, and only OpenShot and the libraries. Installing KDEnlive then worked. It seemed to pull in a lot of KDE desktop stuff, although my desktop manager was still XFCE, and (encouragingly) it didn't break Jack. However, KDEnlive has no direct Jack driver, although I have read posts where people are working on it. In a separate post, I'll ask how to get ALSA working with Jack.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: I can't install KDEnlive   

Back to top Go down
 
I can't install KDEnlive
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
 :: Forums :: Linux Software & Applications-
Jump to: